Skip to content

CCNP ROUTE – ch2

EIGRP Features

> Cisco proprietary protocol.

> EIGRP is a distance vector routing protocol. EIGRP includes advanced features not found in other distance vector protocols, like RIP, which is why it is referred to as an advanced distance vector routing protocol.

> EIGRP uses multicast and unicast rather than broadcast. The multicast address used for EIGRP for IPv4 is 224.0.0.10, and the multicast address for EIGRP for IPv6 is FF00::A.

> One of the key technologies used in EIGRP is RTP (Reliable Transport Protocol), which is used for the reliable exchange of information. EIGRP runs directly above the IP layer as its own protocol, numbered 88. RTP is the component of the EIGRP responsible for guaranteed, ordered delivery of EIGRP packets to all neighbors.

Configuring and Verifying Basic EIGRP for IPv4

ccnp-route-eigrp

R1(config)#router eigrp 1

R1(config-router)#network 192.168.12.0

R1(config-router)#network 192.168.13.0

R1(config-router)#network 192.168.14.0

R1(config-router)#network 172.16.1.0  0.0.0.255


R2(config)#router eigrp 1

R2(config-router)#network 192.168.12.0

R2(config-router)#network 172.16.20.0  0.0.0.255

R2(config-router)#network 172.16.21.0  0.0.0.255

R2(config-router)#network 172.16.22.0  0.0.0.255

R2(config-router)#network 172.16.23.0  0.0.0.255


R3(config)#router eigrp 1

R3(config-router)#network 192.168.13.0

R3(config-router)#network 172.16.32.0  0.0.0.255

R3(config-router)#network 172.16.33.0  0.0.0.255

R3(config-router)#network 172.16.34.0  0.0.0.255

R3(config-router)#network 172.16.35.0  0.0.0.255


R4(config-router)#network 192.168.14.0

R4(config-router)#network 172.16.40.0  0.0.0.255

R4(config-router)#network 172.16.41.0  0.0.0.255

R4(config-router)#network 172.16.42.0  0.0.0.255

R4(config-router)#network 172.16.43.0  0.0.0.255

R4(config-router)#network 172.16.44.0  0.0.0.255

R4(config-router)#network 172.16.45.0  0.0.0.255

R4(config-router)#network 172.16.46.0  0.0.0.255

R4(config-router)#network 172.16.47.0  0.0.0.255


> Yeni IOS larda EIGRP de Automatic Network summarization disabled gelir.

R1#sh ip protocols
Routing Protocol is "eigrp 1"
 Outgoing update filter list for all interfaces is not set
 Incoming update filter list for all interfaces is not set
 Default networks flagged in outgoing updates
 Default networks accepted from incoming updates
 EIGRP-IPv4 Protocol for AS(1)
 Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
 NSF-aware route hold timer is 240
 Router-ID: 172.16.1.1
 Topology : 0 (base)
 Active Timer: 3 min
 Distance: internal 90 external 170
 Maximum path: 4
 Maximum hopcount 100
 Maximum metric variance 1

 Automatic Summarization: disabled
 Maximum path: 4
 Routing for Networks:
 172.16.1.0/24
 192.168.12.0
 192.168.13.0
 192.168.14.0
 Routing Information Sources:
 Gateway Distance Last Update
 Distance: internal 90 external 170


Passive Interface 

R1(config)#router eigrp 1

R1(config-router)#passive-interface default

R1(config)#router eigrp 1

R1(config-router)#no passive-interface serial 3/3

R1(config-router)#no passive-interface fastEthernet 1/0

R1(config-router)#no passive-interface fastEthernet 1/1

R1(config)#router eigrp 1

R1(config-router)#passive-interface serial 3/3



R1#show ip eigrp interfaces detail
Se3/3 
 Hello-interval is 5, Hold-time is 15
 Split-horizon is enabled
Fa1/0 
 Hello-interval is 5, Hold-time is 15
 Split-horizon is enabled
Fa1/1 
 Hello-interval is 5, Hold-time is 15
 Split-horizon is enabled
Lo0 
 Hello-interval is 5, Hold-time is 15
 Split-horizon is enabled


EIGRP METRIC

EIGRP de composite metric kullanılır.

Metric = [(K1 * Bandwidth + [(K2 * Bandwidth) / (256 – Load)] + K3 * Delay) * K5/(K4 + Reliability)] * 256

delay > fastethernet interface ler için : 100 microsecond, gigabit interface ler için : 10 microsecond , serial interface ler için : 20000 microsecond

Bandwidth hesaplanırken hedefe giderkenki minimum değer göz önüne alınır.

BW = 10.000.000 / int bw (kbit)

metric = [bw + (sum of delay) / 10] * 256

 

R1#sh ip route  172.16.20.1

Routing entry for 172.16.20.0/24

Known via "eigrp 1", distance 90, metric 2297856, type internal

Redistributing via eigrp 1

Last update from 192.168.12.2 on Serial3/3, 01:16:08 ago

Routing Descriptor Blocks:

* 192.168.12.2, from 192.168.12.2, 01:16:08 ago, via Serial3/3

Route metric is 2297856, traffic share count is 1

Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 1/255, Hops 1


R1#sh inter loopback 0

Loopback0 is up, line protocol is up

Hardware is Loopback

Internet address is 172.16.1.1/24

MTU 1514 bytes, BW 8000000 Kbit/sec, DLY 5000 usec,


R1#sh inter serial 3/3

Serial3/3 is up, line protocol is up

Hardware is M4T

Internet address is 192.168.12.1/24

MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,



DUAL (Diffusing Update Algorithm)

1>> successor : hedef network e bizi en iyi cost ile (en küçük metrik) ulaştıran router a denir. Successor olarak topology tablosunda bizi o networke en iyi metrikle ulaştıran router ın bize bakan interface inin ip adresi tutulmaktadır.

2>> feasible distance : hedef network e bizi en iyi cost ile götüren rotanın toplam metrik değeridir. Toplam dememizin nedeni bizim successor ile aramızda hesaplanan metric ile successor un hedef network e giderkenki kendi metrik (reported veya advertised distance) toplamıdır.

3>> advertised (reported) distance : Bizim komşumuzun bir hedef network e giderken bize bildiriği metrik değeridir. Bizim router ımız bu rapor edilen metric ile komşuyla arasındaki metric değerini toplar ve o hedef network için toplam metric değerini bulur. (FD)

4>> feasible successor : topolojide hedef bir network için successor un yanısıra alternatif bir yol varsa loop-free backup path olarak kullanılabilir. İşte bu alternatif rotaya feasible successor denir. Bir alternatif rotanın feasible successor olabilmesi için feasible condition u (feasiblity contion) sağlaması gerekir.

5>> feasibility condition : bizi bir hedef network e successor un yanısıra alternatif olarak bağlayabilecek komşumuzun o hedef rotaya olan kendi metric i (bizim ile aramızda olan metric i göz önüne alınmıyor) diğer bir deyişle bize rapor ettiği metric değeri (reported distance / advertised distance) bizim successor rotamızın toplam metric değerinden (feasible distance) küçük ise bu rota feasible successor olarak topology table a işlenir.

“show ip route” komutu ile bakıldığında routing tablosunda sadece successor gözükür. Feasible successor gözükmez. “show ip eigrp topology” komutu ile successor ve feasible successor görülebilir. Eğer bu komut ile successor un altında bir rota daha gözüküyorsa bunun anlamı feasibility condition sağlanmıştır. Eğer feasibility condition sağlanmazsa bu rota “show ip eigrp topology” komutu ile bakıldığında gözükmez. Bu feasibility condition u sağlamayan rotayı görebilmek için “show ip eigrp topology all-link” komutu kullanılmalıdır.

> show ip route çıktısında daima en iyi route (successor) gözükür.

> eğer feasibility condition sağlanmış ise "show ip eigrp topology" komutu çıktısında feasible successor de gözükür.

> eğer feasibility condition sağlanmamış ise ve gerçekten de bir alternatif route var ise "show ip eigrp topology" komutu çıktısında bu alternatif route gözükmez. Lakin "show ip eigrp topology all-links" komutu çıktısında bu feasible condition u sağlamayan alternatif route gözükür.

EIGRP Stub Routers

The stability of large-scale EIGRP networks often depends on the scope of queries through the network. One way you can reduce the number of EIGRP queries and improve network scaling is to mark the spokes of a large network as stubs. The EIGRP stub routing feature enables you to limit query message scope in the network. Routers configured as stubs do not forward EIGRP learned routes to other neighbors, and more importantly, non-stub routers do not send query messages to stub routers. This saves CPU cycles and bandwidth and speeds up convergence.

R4(config-router)#eigrp stub ?

  connected      Do advertise connected routes

  leak-map       Allow dynamic prefixes based on the leak-map

  receive-only   Set receive only neighbor

  redistributed  Do advertise redistributed routes

  static         Do advertise static routes

  summary        Do advertise summary routes
R4(config-router)#eigrp stub


R1#sh ip eigrp neighbors detail

192.168.14.4   Fa1/1   

   Version 10.0/2.0, Retrans: 0, Retries: 0, Prefixes: 9

   Topology-ids from peer - 0

   Stub Peer Advertising (CONNECTED SUMMARY ) Routes

   Suppressing queries
R4#sh ip protocols

Routing Protocol is "eigrp 1"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP-IPv4 Protocol for AS(1)

Metric weight K1=1, K2=0, K3=1, K4=0, K5=0

NSF-aware route hold timer is 240

Router-ID: 172.16.47.1

Stub, connected, summary


R4(config)#router eigrp 1

R4(config-router)#eigrp stub receive-only

eigrp stub receive-only bir NAT router da anlamlı olacaktır. 


R4#sh ip protocols

Stub, receive-only

R1#sh ip eigrp neighbors detail fa 1/1

Receive-Only Peer Advertising (No) Routes

Suppressing queries