Skip to content

CCNA 2 – ch7

Dynamic Routing

The purpose of dynamic routing protocols includes:

> Discovery of remote networks
> Maintaining up-to-date routing information
> Choosing the best path to destination networks
> Ability to find a new best path if the current path is no longer available

The main components of dynamic routing protocols include:
> Data structures - Routing protocols typically use tables or databases for its operations. This information is kept in RAM.
> Routing protocol messages - Routing protocols use various types of messages to discover neighboring routers, exchange routing information, and other tasks to learn and maintain accurate information about the network.
> Algorithm - An algorithm is a finite list of steps used to accomplish a task. Routing protocols use algorithms for facilitating routing information and for best path determination.

An autonomous system (AS) is a collection of routers under a common administration such as a company or an organization. An AS is also known as a routing domain. Typical examples of an AS are a company’s internal network and an ISP’s network.

Convergence : The network has converged when all routers have complete and accurate information about the entire network. Convergence time is the time it takes routers to share information, calculate best paths, and update their routing tables. A network is not completely operable until the network has converged; therefore, most networks require short convergence times.

RIPv1

> distance vector
> classful
> periodic updates (30sn)
> updates are broadcast (255.255.255.255)
> 15 hop tan sonrasına desteği yoktur.
> metric is hop count
> update ler UDP 520. porttan gider ve gelir

ripv1

R1(config)#router rip
R1(config-router)#network 192.168.1.0
R1(config-router)#network 192.168.11.0
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0

R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.22.0
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0

R3(config)#router rip
R3(config-router)#net
R3(config-router)#network 192.168.3.0
R3(config-router)#network 192.168.33.0
R3(config-router)#network 192.168.13.0
R3(config-router)#network 192.168.23.0

 

RIPv2

> distance vector
> classless
> periodic updates (30sn)
> updates are multicast (224.0.0.9)
> 15 hop tan sonrasına desteği yoktur.
> metric is hop count
> update ler UDP 520. porttan gider ve gelir
> automatic network summarization default ta aktiftir.
ripv2

 

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.16.0.0
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 172.16.0.0
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 172.16.0.0
R3(config-router)#network 192.168.13.0
R3(config-router)#network 192.168.23.0

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 24 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial2/0 2 2
Serial3/0 2 2
Automatic network summarization is in effect
Maximum path: 4

RIPv2 'de automatic network summarization default ta aktif olduğu için
Router lar subnetler yerine sınıfı anons ederler. Bunu düzeltmek için :

R1(config)#router rip
R1(config-router)#no auto-summary
R2(config)#router rip
R2(config-router)#no auto-summary
R3(config)#router rip
R3(config-router)#no auto-summary
R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 24 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial2/0 2 2
Serial3/0 2 2
Automatic network summarization is not in effect
Maximum path: 4


Passive interface

Hem güvenlik hem de efektiflik açısından router olmayan sadece host olan interface lere update göndermek ya da update almak istenilmez. Bunu gerçekleştirebilmek için passive-interface uygulaması yapılır.

R1(config)#router rip
R1(config-router)#passive-interface fastEthernet 0/0
R1(config-router)#passive-interface fastEthernet 1/0

 

Default route propagation

R1(config)#interface loopback 0
R1(config-if)#ip address 1.2.3.4 255.255.255.248

R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 0

R1(config)#router rip
R1(config-router)#default-information originate