Skip to content

Chapter 2

Router lar boş configuration ile açıldığında basic management setup a girmek isteyip istemediğimizi sorar. Normalde "no" diyerek bu mode a girmiyoruz. Yanlışlıkla "yes" diyerek girersek "CTRL + C" ile çıkılabilir.

IOS Configuration Modes

User Exec Mode

Bu mode da cihazda configuration yapılamaz. Monitoring, test maksatlı komutlar bu mode da çalışır. Bu mode da iken cihaz adının sonunda büyüktür " > "işareti gözükür.
Router>    Switch>

Privileged Exec Mode (enable)

Bu mode da her türlü yetkiye sahip olunur. Genelde bu mode da configuration yapılmaz. Bu mode da iken cihaz adının sonunda diyez " # "işareti gözükür.

Router>enable
Router#

Global Configuration Mode

Bu mode da cihazda global configuration lar yapılır.

Router#configure terminal
Router(config)#

Specific Mode

Bu mode da spesifik olarak bir interface, bir protocol vb. configuration yapılır.

Router(config)#interface fa 0/0
Router(config-if)#
Router(config)#router rip
Router(config-router)#

•     Bir önceki mode a dönmek için " exit " komutu kullanılabilir

Router(config-if)#exit
Router(config)#exit
Router#

•     Privileged mode dan user mode a geri dönmek için " disable " komutu girilir

Router#disable
Router>

•     " end " komutu kullanılarak specific bir mode dan privileged mode a direk geçilebilir.

Router(config-if)#end
Router#

•     " Tab " tuşu komutları tamamlamak için kullanılır.

•     " ? " ile yardım alınabilir.

•     Eğer ki komut çıktısı bir sayfaya sığmıyor ise ekranda " more " ifadesi gözükecektir. Bu durumda " enter " a basılarak komut çıktısının geri kalanı satır satır gösterilebilirken, " space " e basılarak sayfa sayfa gösterilebilir.

•     " CTRL + Z " komutu  " end " komutu ile aynı işi yapar.

•     " CTRL + SHIFT + 6 " komutu yanlış bir kelime girildiğinde prosesi iptal etmek için kullanılır.

•     Router#show clock  komutu ile cihazın tarih ve zaman bilgisi görülebilir

•     Yukarı ve aşağı ok tuşları kullanılarak en son girilen 10 komut geri çağırılabilir.

•     " CRTL + A " komutu ile komut satırının başına, " CTRL + E " komutu ile komut satırının sonuna gidilir.

 

IOS Hata Mesajları

1) Belirsiz (muğlak) komut hatası

Router#cl
% Ambiguous command: "cl"

2) Tamamlanmamış komut hatası

Router#clo
% Incomplete command.

3) Yanlış girdi hatası

Router#clock set 16:25:00 9 10
______________________________^
% Invalid input detected at '^' marker.

Router#clock set 16:25:00 9 october 2016

•     Cihazın adını değiştirmek için :

Router(config)#hostname ccna1
ccna1(config)#

•     Console şifresi vermek için :

ccna1(config)#line console 0
ccna1(config-line)#password cisco
ccna1(config-line)#login

•     Enable şifresi vermek için

ccna1(config)#enable password class

•     ccna1#show running-config  komutu ile cihazda koşulan configuration görülebilir.

•     Basit bir algoritma ile şifreleri encypted yapmak için :

ccna1(config)#service password-encryption

•     " enable password " komutu işe şifre verildiğinde bu şifre " service password-encryption " ile encrypted edilse bile decrypt olması oldukça kolaydır. (http://www.ifm.net.nz/cookbooks/passwordcracker.html)

Enable şifresini daha güvenli hale getirmek için " enable secret " komutu kullanılmalıdır :

ccna1(config)#no enable password
ccna1(config)#enable secret class

•     Bir host un bulunduğu network teki hostlara ve diğer network lerdeki host lara erişebilmesi 3+1 bilgiye ihtiyacı vardır.

1) Her bir hostun unique (eşsiz) bir ip adresi olmalıdır.
2) Her bir host un bulunduğu network ü gösteren subnet mask bilgisi olmalıdır.
3) Host un bulunduğu network dışındaki diğer host lara erişebilmesi için default gateway bilgisinin olması gerekir.
4) Dns bilgisi

•     Router un her interface i ayrı bir network dür.

•     Default olarak router ın tüm interface leri kapalıdır (shutdown). Açmak için :

ccna1(config)#interface fastEthernet 0/1
ccna1(config-if)#no shutdown

•     Router ın bir interface ine ip address ataması yapmak için

ccna1(config)#interface fastEthernet 0/1
ccna1(config-if)#ip address 192.168.1.254 255.255.255.0

•     Router ı telnete açmak için :

ccna1(config)#line vty ?
<0-15> First Line number
ccna1(config)#line vty 0 4    >>> eş zamanlı 5 telnet bağlantısı
ccna1(config-line)#password itubidb
ccna1(config-line)#login

•     Enable şifresi verilmemiş ve telnete açılmış bir cihaza telnet yapılsa bile enable mode geçmek mümkün değildir.

PC>telnet 192.168.1.254
Trying 192.168.1.254 ...Open

User Access Verification

Password:
ccna1>en
% No password set.   !!!

•     Banner tanımlamak için :

ccna1(config)#banner motd #
Enter TEXT message. End with the character '#'.
itu bidb
cisco lab
cihazda guncelleme var
dokunmayin !!!
#

•     Description yazmak için :

ccna1(config)#interface fa 0/1
ccna1(config-if)#description ?
LINE Up to 240 characters describing this interface
ccna1(config-if)#description lokal ag baglantisi

•     Configuration kaydetmek için :

ccna1#copy running-config startup-config

•     ccna1#show startup-config  komutu ile cihazdaki kayıtlı configuration görülebilir.

•     Mevcut bir configuration u silmek için :

router#erase startup-config
router#reload

ccna1#show ip interface brief
Interface             IP-Address       OK?      Method            Status                             Protocol

FastEthernet0/0 unassigned      YES      unset           administratively down     down

FastEthernet0/1 192.168.1.254  YES     manual            up                                     up

•    Switch lerin çalışmak için ip address lerine ihtiyaçları yoktur. Switch lere ip adresi vermemizin sebebi management maksatlıdır. Yani onlara uzaktan (telnet, ssh) bağlantı yapmak içindir.

•    Switch ler ip address lerine göre iş yapmayan cihazlardır. Bu sebeple switch in fiziksel interface lerine ip addresi verilemez. Switch in ip adresi SVI (switch virtual interface) ya verilir :

Switch>en
Switch#conf t
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.254